Using HttpResponseMessage<T> response results in no help

Topics: Web Api
Oct 5, 2011 at 6:55 PM

Using HttpReponseMessage<T> return value for my api methods causes the /help generated to be missing the types and instead says "Could not generate schema document".

If the help generate can't pull the type T for help generation is there an attribute we can decorate the method with that will tell the help what type use for creation of schema in the help documentation?

Coordinator
Oct 5, 2011 at 8:14 PM

Thank you for reporting this issue. Could you please file an issue in Issue Tracker with a simple project that reproduces the issue so that we can take a look?

Daniel Roth

From: jj12345 [email removed]
Sent: Wednesday, October 05, 2011 11:55 AM
To: Daniel Roth
Subject: Using HttpResponseMessage<T> response results in no help [wcf:274894]

From: jj12345

Using HttpReponseMessage<T> return value for my api methods causes the /help generated to be missing the types and instead says "Could not generate schema document".

If the help generate can't pull the type T for help generation is there an attribute we can decorate the method with that will tell the help what type use for creation of schema in the help documentation?

Oct 5, 2011 at 9:24 PM
Edited Oct 5, 2011 at 9:25 PM
Issue created with attachment reproducing the issue.  Issue title is "HttpReponseMessage<T> return value = no help on return value"

danroth27 wrote:

Thank you for reporting this issue. Could you please file an issue in Issue Tracker with a simple project that reproduces the issue so that we can take a look?

 

Daniel Roth

 

From: jj12345 [email removed]
Sent: Wednesday, October 05, 2011 11:55 AM
To: Daniel Roth
Subject: Using HttpResponseMessage<T> response results in no help [wcf:274894]

 

From: jj12345

Using HttpReponseMessage<T> return value for my api methods causes the /help generated to be missing the types and instead says "Could not generate schema document".

If the help generate can't pull the type T for help generation is there an attribute we can decorate the method with that will tell the help what type use for creation of schema in the help documentation?

Dec 14, 2011 at 10:40 PM

I upvoted the Issue in the Tracker. It seems this is pretty important...