wcf preview 4 ssl on IIS 6

Topics: Web Api
Sep 22, 2011 at 1:06 AM

I keep getting the following error when we release our WCF to production with a Godaddy SSL.

 

The provided URI scheme 'https' is invalid; expected 'http'.
Parameter name: context.ListenUriBaseAddress

 

what am I doing wrong? according to this link http://social.msdn.microsoft.com/Forums/en/wcf/thread/d29a420d-5ba8-4743-9159-e2956870b68b?prof=required no change is required to make the service available through ssl.

 

my web.config below:

 

 <system.web>
  <compilation debug="false" targetFramework="4.0" />
 </system.web>
 <system.webServer>
  <modules runAllManagedModulesForAllRequests="true">
   <add name="UrlRoutingModule" type="System.Web.Routing.UrlRoutingModule, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
  </modules>
 </system.webServer>
 <system.serviceModel>
  <bindings>
   <webHttpBinding>
    <binding>
     <security mode="Transport" />
    </binding>
   </webHttpBinding>
  </bindings>
  <behaviors>
   <serviceBehaviors>
    <behavior>
     <serviceAuthorization serviceAuthorizationManagerType="SS.Services.APIAuthorization, SS.Services" />
    </behavior>
   </serviceBehaviors>
  </behaviors>
  <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />
  <standardEndpoints>
   <webHttpEndpoint>
    <!-- 
   Configure the WCF REST service base address via the global.asax.cs file and the default endpoint 
   via the attributes on the <standardEndpoint> element below
  -->
    <standardEndpoint name="" helpEnabled="true" automaticFormatSelectionEnabled="false"/>
   </webHttpEndpoint>
  </standardEndpoints>
 </system.serviceModel>
Sep 24, 2011 at 12:14 AM

Anyone running wcf on iis 6? please we need to turn on ssl! deadline approaching! :S

 

thanks in advanced.

Sep 24, 2011 at 1:30 AM

I am not an expert on IIS 6 but it looks like your IIS server is configured to using HTTP and not HTTPS. My suggestion would be to look at the IIS configuration and verify that SSL has been turned on. You may also have to turn *off* regular HTTP at the same time so that there is no confusion as to whether it is HTTP or HTTPS.

Here [2] is information for configuring SSL for IIS 6 – it is linked from [1] where you can find additional information as well.

Hope this helps,

Henrik

[1] http://msdn.microsoft.com/en-us/library/ms734679.aspx

[2] http://technet.microsoft.com/en-us/library/cc736992(WS.10).aspx

Nov 3, 2011 at 1:02 AM

Hi HenriKN...

we have some other sites on IIS6 that run under SSL...so I assume IIS6 is configured for HTTPS right?

or are we talking about different settings?

Please advise